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Notice

Every effort was made to ensure that the information in this manual was accurate at the time of 
printing. However, information is subject to change without notice, and JDS Uniphase reserves the 
right to provide an addendum to this manual with information not available at the time that this 
manual was created.

Copyright 

© Copyright 2014 JDS Uniphase Corporation. All rights reserved. JDSU and the JDSU logo are 
trademarks of JDS Uniphase Corporation (“JDS Uniphase”). All other trademarks and registered 
trademarks are the property of their respective owners. No part of this guide may be reproduced or 
transmitted electronically or otherwise without written permission of the publisher.

Copyright release 

Reproduction and distribution of this guide is authorized for Government purposes only.

Trademarks

JDSU, the JDSU logo, J-Reporter, and Certifier40G are trademarks or registered trademarks of 
JDSU in the United States and/or other countries.

Microsoft, Windows, Windows Mobile and Windows Mobile Device Center are either registered 
trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Specifications, terms, and conditions are subject to change without notice. All trademarks and regis-
tered trademarks are the property of their respective companies.

Terms and conditions

Specifications, terms, and conditions are subject to change without notice. The provision of hard-
ware, services, and/or software are subject to JDSU’s standard terms and conditions, available at 
www.jdsu.com/terms.

http://www.JDSU.com/terms
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About This Guide

The topics discussed in this section are as follows:

– “Purpose and Scope” on page vi

– “Assumptions” on page vi

– “Related Information” on page vi

– “Conventions” on page vii

– “Technical Assistance” on page viii
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Purpose and Scope

The purpose of this guide is to help you successfully use the J-Reporter features and capabilities. 
This guide includes task-based instructions that describe how to install, configure, use, and trouble-
shoot the J-Reporter. Additionally, this guide provides a complete description of JDSU’s warranty, 
services, and repair information, including terms and conditions of the licensing agreement.

Assumptions
This guide is intended for novice, intermediate, and experienced users who want to use the 
J-Reporter effectively and efficiently. We are assuming that you have basic computer and mouse/
track ball experience and are familiar with basic telecommunication concepts and terminology.

Related Information

Use this guide in conjunction with the following information:

J-Reporter Installation Guide — This guide provides instructions on the system requirements for 
J-Reporter and how to install the J-Reporter software on your 
computer. 



About This Guide
Conventions

P/N 22057094, Rev. 0 J-Reporter User’s Guide vii
March 2014

Conventions

This guide uses typographical and symbols conventions as described in the following tables.

Table 2 Symbol conventions

Table 1 Text formatting and other typographical conventions

Item(s) Example(s)

Buttons, keys, or switches that you 
press or flip on a physical device.

Press the On button.

Press the Enter key.

– Flip the Power switch to the on position.

Buttons, links, menus, menu options, 
tabs, or fields on a PC-based or 
Web-based user interface that you 
click, select, or type information into.

Click Start.

– Click File > Properties.

– Click the Properties tab.

– Type the name of the probe in the Probe Name field.

Directory names, file names, and 
code and output messages that 
appear in a command line interface 
or in some graphical user interfaces 
(GUIs).

$NANGT_DATA_DIR/results (directory) 

– test_products/users/defaultUser.xml (file name)

– All results okay. (output message)

Text you must type exactly as shown 
into a command line interface, text 
file, or a GUI text field.

– Restart the applications on the server using the following 
command:
$BASEDIR/startup/npiu_init restart

Type: a:\set.exe in the dialog box. 

References to guides, books, and 
other publications appear in this 
typeface.

Refer to Newton’s Telecom Dictionary. .

Command line option separators. platform [a|b|e] 

Optional arguments (text variables in 
code).

login [platform name] 

Required arguments (text variables 
in code).

<password> 

This symbol represents a general hazard. It may be associated with either a DANGER, WARN-
ING, or CAUTION message. See Table 3 for more information.

This symbol represents hazardous voltages. It may be associated with either a DANGER, 
WARNING, or CAUTION message. See Table 3 for more information.

This symbol represents a risk of explosion. It may be associated with either a DANGER, WARN-
ING, or CAUTION message. See Table 3 for more information.



About This Guide
Technical Assistance

viii J-Reporter User’s Guide P/N 22057094, Rev. 0
March 2014

Table 3 Safety definitions

Technical Assistance 

Table 4 lists contact information for technical assistance. For the latest TAC information, go to 
www.jdsu.com or contact your local sales office for assistance. Contact information for regional 
sales headquarters is listed on the back cover of this manual.

During off-hours, you can request assistance by doing one of the following: leave a voice mail 
message at the Technical Assistance number, e-mail the North American Technical Assistance 
Center, tac@jdsu.com, or submit your question using our online Technical Assistance Request form 
at www.jdsu.com.

This symbol indicates a note that includes important supplemental information or tips related to 
the main text.

This symbol, located on the equipment, battery, or the packaging indicates that the equipment or 
battery must not be disposed of in a land-fill site or as municipal waste, and should be disposed 
of according to your national regulations.

CAUTION Indicates a situation that, if not avoided, could result in loss of data or a disruption of 
software operation. 

Table 4 Technical assistance centers

Region Phone Number

Americas 1-855-ASK-JDSU (option #3)

1 301 353 1560

(1-855-275-5378, option #3)

tac@jdsu.com

Europe, Africa, and Mid-East +49 (0) 7121 86 1345 

(JDSU Germany)

hotline.europe@jdsu.com

Asia and the Pacific +852 2892 0990 
(Hong Kong)

+86 10 6655 5988
(Beijing-China)

http://www.jdsu.com
mailto:tac@jdsu.com
mailto:hotline.germany@jdsu.com
mailto:tac@jdsu.com
http://www.jdsu.com
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1
Chapter 1Introduction

This chapter describes the system requirements and how to start J-Reporter. The topics discussed 
in this chapter are as follows:

– “About J-Reporter” on page 2

– “Running the Program” on page 2

Please ensure JDSU J-Reporter has been installed into you workstation before you proceed 
further. Please refer to Installation Guide for detailed instructions on how to obtain and install
J-Reporter.
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About J-Reporter

J-Reporter is a software program that works seamlessly with JDSU’s Certifier40G. This software 
has undergone numerous qualitative and functional tests to ensure the latest version meets the 
latest industrial standards and trend requirements. 

This guide contains information about and instructions on how to use the J-Reporter software.

System requirements are listed in the J-Reporter Installation Guide.

Running the Program

1 Double click on the J-Reporter shortcut icon on your desktop to start the program. You may 
also click the Windows Start button and enter JReporter into the search box. 

2 The program will start by displaying the version number as shown below.  
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2
Chapter 2Project Management

This chapter describes how to use the J-Reporter to manage projects and import, export, and view 
the test results. The topics discussed in this chapter are as follows:

– “Creating a New Project” on page 4

– “Opening an Existing Project” on page 5

– “Importing the Test Results from a Device” on page 6

– “Importing the Test Results from a USB Flash Drive” on page 8

– “Exporting the Test Results” on page 9

– “Viewing the Device on your Workstation” on page 10
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Creating a New Project

1 By default, a new project will be created when you run the program. 
Alternatively, select File > New Project or click the  New Project icon. 

2 You will be prompted to save your file when you create a new project. Choose where the new 
project file will be saved and click ‘Save’ to proceed. 

3 Right-clicking the icons in the left panel will display the following options:  

> Add – Adds a new site to the selected project 

>> Building – Adds a new building sub-item to the selected site

>>> New Floor – Adds a new floor sub-item to the selected building

>>>> New Room – Adds a new room sub-item to the selected floor

>>>>> New Rack – Adds a new rack sub-item to the selected room

>>>>>> New Panel – Adds a new panel sub-item to the selected rack
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Once the menu hierarchy is selected, the left panel can resemble the following. 

Opening an Existing Project

1 Select File > Open or click the  Open Project icon. 

Locate your project (*.prx) file and click ‘Open’ to proceed. 

> Rename – Renames the selected item

> Delete – Deletes the selected item

> Close Project – Closes the selected project
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Importing the Test Results from a Device

1 Ensure Certifier40G is connected to your workstation via an USB cable. 

2 You may be prompted to install Microsoft Windows Mobile Device Center.  Click ‘Accept’ to 
install the required drivers. 

3 The Status bar will indicate “Connected” once your workstation is linked to the device.  

4 Select Import > Device or click the   ‘Device’ icon as shown below. 
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5 Select the test results you wish to import and click ‘Import Selected’ to proceed or you can click 
‘Import All’ to import all test results. 

6 Please wait while the import process begins or click ‘OK’ to start it. 

7 The Status bar will display the “Transferring” message during the import process. 
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Importing the Test Results from a USB Flash Drive

1 Select Import > USB Flash Drive or click the  ‘USB Flash Drive’ icon as shown below. 

2 Select the drive you wish to import the test results from. Click ‘Import’ to proceed. 

3 Select the test results you wish to import and click ‘Import Selected’ to proceed or you can click 
‘Import All’ to import all test results. 

4 The Status bar will display the “Transferring” message during the import process. 
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Exporting the Test Results 

1 Export the selected test report based on the file format.

– Select Export > PDF to export the selected test report in PDF format. 

– Select Export > CSV to export the selected test report in CSV format. 

2 You will be given the option to import “Only selected result(s)” or “All result(s)” after selecting 
either  ‘Summary’ or ‘Detailed’ test results. Select the required test report options and click ‘OK’ 
to proceed. 
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3 You will be prompted to save the exported results after selecting either ‘Summary’ or ‘Detail’. 
Choose the directory in which to save the results, enter a file name and click ‘Save’ to proceed. 

Viewing the Device on your Workstation

1 After Certifier40G is connected to your workstation, click the device icon  next to the 
  indicator on the status bar as shown below. 

2 Choose ‘Device Information’ to view the device’s serial number, software version 
and calibration date. 

3 Choose ‘Remote Display’ to access the Local unit remotely via your workstation. 

Accessing this option will allow advanced functions such as screen capturing (image), action 
recording (video), screen magnifying (zoom), etc. 
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3
Chapter 3Data Management

This chapter describes the functionality of the J-Reporter software. Topics discussed in this chapter 
are as follows:

– “Viewing the Test Results” on page 12

– “Viewing the Test Results – Inverting Y Axis” on page 16

– “Viewing the Test Results – Linear & Logarithmic” on page 17

– “Viewing the Test Results – Markers” on page 18

– “Editing Information” on page 19

– “Searching for Information” on page 22
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Viewing the Test Results 

1 After importing the test results, summarized data will be displayed. 

– Clicking on the Project name displays all test results.

– Clicking on the Site name displays only test results saved within the site.   
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2 Double clicking a test result will display more comprehensive results of the test.

– The ‘Overview’ tab displays the summary of the selected results. 

– The ‘Test Settings’ tab displays the configurations used for the selected results. 
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– The ‘Test Probes’ tab displays information on the hardware used to obtain the results. 

3 Click on the individual tab to display chart, worst marker and other detailed information. 
Examples of each of the ten tabs are displayed in the following table. 

 

 Insertion Loss Return Loss

NEXT PSNEXT
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ACRF PSACRF

Length & Delay Resistance

NEXT Locator RL Locator
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Viewing the Test Results – Inverting Y Axis

Select Settings > Y Axis (Vertical) Orientation > Inverted to display the test results table inverted 
along the Y axis  

  

 Default Chart Inverted Chart
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Viewing the Test Results – Linear & Logarithmic 

Select Settings > X Axis (Horizontal) Orientation  

Linear – default 
 

Logarithmic 
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Viewing the Test Results – Markers

Select Settings > Markers 

Ethernet Standards – Additional markers indicating frequencies of various Ethernet standards 
will be indicated for reference. E.g, 10BASE-T, 100BASE-T, 10GBASE-T & 40GBASE-T.

 

Worst Markers – Default 
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Editing Information

1 Right click at the results selection screen (right panel).   

2 Select Rename > Cable Label to rename the selected result as shown. 
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3 Select Rename > Operator Name to rename the selected result. 
The renamed Operator Name will be reflected at the ‘Test Settings’ tab in the detail results. 

4 Select Replace > Cable Label to find words you wished to replace on the selected result(s). 

5 Select Replace > Operator Name to rename the selected result. 
As with the renamed operator described in step 3 above, the replaced Operator Name will be 
reflected at the ‘Test Settings’ tab in the detail results. 
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6 Select Delete to permanently delete a test result. Click ‘Yes’ to proceed. 

7 Select Conversion > Cable Pairing to change between T568A to T568B cable pairing and 
T568B to T568A pairing. Default setting uses the T568B cable pairing. 

8 Select Properties to view user editable information on the selected result. 
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Searching for Information

1 Select type of search from the drop-down menu and input search value in the search field or 
select from the additional search options. 

2 Press ‘Enter’ or click the ‘Search’ icon on the left to begin search.
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4
Chapter 4Setting Preferences

This chapter provides instructions for setting your preferences used by J-Reporter. Topics 
discussed in this chapter are:

– “Personalizing the Test Results” on page 24

– “Choosing the Length Units” on page 25

– “Choosing the Report Format” on page 26

– “Selecting the Language” on page 27
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Personalizing the Test Results

1 Select Settings > Company Details to personalize test results with your corporate logo and 
company name.

2 Enter your company’s name and click on the empty space to browse for image of the logo. 
Recommended size for logo – 32 x 32px or 32 x 128px. Click ‘OK’ to save. 

3 Your company’s name and corporate logo will be displayed on the top left hand corner of the 
next result exported. 
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Choosing the Length Units

1 Select Settings > Length Unit to choose the length units to be displayed in either Meters or 
Feet on the test results.  
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Choosing the Report Format 

1 Select Settings > Report Format to choose the format of the report.

– Calibration Date (default) – last calibration date of the Certifier40G will be indicated on the 
report 

– Y-axis Inverted – all test results will generate charts with the Y-axis inverted 
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Selecting the Language   

In addition to English, the default language, the following languages are available: 

Deutsch, Espanol, Simplified & Traditional Chinese, Finnish, Francaise, and Polska

1 Select Languages and choose your preferred language. 

2 Once you select a language, you will be prompted to restart J-Reporter. Click ‘OK’ to restart. 
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5
Chapter 5Updating Device Software

This chapter describes how the J-Reporter software can be updated when new versions 
are available. Topics discussed in this chapter are as follows:

– “Updating the Device Software” on page 30
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Updating the Device Software

1 Select Tools > Update Device Software. 

2 Ensure a USB flash drive has been connected to your workstation before proceeding with 
update.

In the event the USB flash disk is not present, you will be reminded to insert one.

3 Click ‘OK’ after reading the information message to proceed. 

4 Click ‘OK’ to proceed with the update. 

5 The Status bar will display the “Processing” status during the upgrade.  
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6 You will be informed when the upgrade is complete. Click ‘OK’ to proceed. 

7 The files are now stored in folder “RXPert” folder on the USB flash disk. 
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